Online cars are very shaky

Discussion in 'Race 07 - Official WTCC Game' started by Matt Fearon, Sep 12, 2013.

  1. Matt Fearon Licensed Driver

    Hey guys, just got done playing my first two rounds of Race 07 online and I had a BLAST. I have an issue though, everyone in the lobby shows up and all the cars look great until I get close and then they get very shaky, like it looks like everyone's car has had way too much caffeine. I have no issues like this online, so does anyone know how I might be able to fix it?

  2. Guy Moulton Licensed Driver

    That is normal with r07. Just make sure you don't have anything or anyone online in the background. Netflix is a notorious bandwidth hog and if someone is watching a movie while you are trying to race online, this sort of network jitter will happen.
    • Informative Informative x 1
    • List
  3. Andy Breedon SRP Manager

    I thought that was slightly too high graphic settings, could try that.
  4. Rob Hermans SRP Manager

    Before recommending any changes to your settings, I would want to know the specs of your rig. It would also be worth investigating the quality and speed of your connection to the server. You could publish your result, but it wouldn't really give a good indication of your connection speed to a server which is on the other side of the world. As an example, here are my results when connecting to a server in my own country (LEFT) and to a server in New York (RIGHT):

    [IMG] [IMG]

    The difference in the ping is quite marked. You can do a similar test at and see the so-called "jitter". That's not the cars shaking kind of jitter, but it will give an idea of the quality of your connection for the purposes of gaming:

    [IMG] [IMG]

    The "line quality" is important: if it's not at least grade C, you might experience problems when gaming. "Packet loss" should be at 0%, or you might get disconnections.
  5. Matt Fearon Licensed Driver

    Here are my Speedtest results. Looks pretty good here yeah?

    Here are my Pingtest. I picked NZ for the 2nd one because I was trying to get as far away as possible. Looks ok?
  6. Rob Hermans SRP Manager

    Very good results indeed Matt, I'd say you can rule out connection issues as the cause of the shaky cars problem! Your connection to the game server through the Steam client might still cause some problems; some of our members can speak from personal experience with that. I don't know how to test that, however.

    You do want to check that there are no programs running which might interfere with smooth gameplay and, as Guy pointed out, that there's nothing hogging bandwidth when you're racing. I'd like to see your system's specs, not every little detail is necessary: motherboard/CPU/RAM, GPU+driver version, NVidia settings and in-game settings, plus any performance boosting you're applying (overclocking/graphics enhancement programs). For example, in some games I noticed performance was actually worse when I tried that NV Inspector program you mentioned in your "AA" thread; have you tried turning that off to see if the cars are still messed up? There might be something obvious that needs adjusting, as Andy alluded to.
  7. Matt Fearon Licensed Driver

    You guys are the best! I will post all my specs and settings when I get home this afternoon, thanks for taking the time guys!
  8. Ryan Walker Licensed Driver

    Hope you guys don't mind me posting on this topic as I get the same problem sometimes as well.

    PC Specs:
    Operating System: Windows 7 64 bit
    Processor: i3-2100 CPU@ 3.10 GHZ
    RAM: 4080 MB
    Graphics card: ATI Radeon HD 6800 (2792 MB)

    Attached Files:

  9. Matt Fearon Licensed Driver

    Alright guys, here are all the specs I could find:
    My Nvidia Control Panel:
    Inspector Driver and Options info:
    nvid.png inspector steam vers.png
    Simbin Config Settings:
  10. Matt Fearon Licensed Driver

    And Finally, Race 07 Visual Options:
    Not Running any kind of OC on my CPU or GPU at the moment.
  11. Rob Hermans SRP Manager

    Of course we don't mind Ryan, you know you're always welcome here. :)

    First thing I would do is turn the AA off in the RACE config. Check what your CCC settings are and adjust the AA (Andy Breedon is more of an expert on AMD than I am). Have a read of Matt's thread where we discuss AA, I have some screenshots of NVidia control panel in there. Maybe some of the settings might apply to AMD as well.
    Also is that the native resolution of your monitor? I'm guessing it is, it just looks a bit of an odd setting to me.
  12. Rob Hermans SRP Manager

    Matt, your card should be easily capable of running RACE at the highest detail settings, maybe with reduced draw distance if needed. I suggest run it without Inspector and turn the detail right up in-game. Also, turn VSync off in NV control panel and lower the AA mode if you don't get a decent frame rate with the detail turned up.
  13. Matt Fearon Licensed Driver

    But that SGSSA 8X or 4X from the Inspector program is the ONLY thing that has seemed to work in getting rid of the terrible jaggies. I guess I have to choose between looks and performance :'( what a cruel world. I will do as you recommended as soon as I am fully awake and feel like going down stairs, thanks Rob!
  14. Andy Breedon SRP Manager

    Agree, they do. I will add my screen shots to Rob's post and amend the title, from there everyone can fine tune their graphics far better than using the sim, especially with RACE07. rF2 however, I am still playing with.
  15. Matt Fearon Licensed Driver

    Well I tried turning V-sync off and it really has a ton of issues when I do that for some reason. Screen tearing CONSTANTLY and it seems like its only running about 20 fps with tons of micro stutters and flashing textures, not just signs and stuff like normal, but pretty much the whole forest around Imola was flashing and driving me crazy. I also turned everything off on the Inspector program but that didn't help with the shaking online cars. I turned my V-sync back to adaptive and put my settings all back and now the game runs smooth again and looks decent enough, its just still having the stuttering online cars issue :(

    EDIT: could just be my TV causing problems? I use a 39" Magnavox HDTV, but I have a 19" HP Monitor that I could try to hook up and see if I still have the same issues with it.
  16. Andy Breedon SRP Manager

    It isnt a monitor problem, i had the same problem with my old card, i found it to be a mixture of drivers and graphic settings.

    Vsync always off in sims etc only good use for fps games imo.

    The more your playing you are seeing different results, about all you can do. Try reducing the car detial to low as it will go and see if that stops it, it should do.
  17. Michael van Scheppingen Licensed Driver

    32x CSAA is your problem...

    Reset graphics driver software default.

    Set: 8x AA & 16x AF and is all you need for Race07

    Vsync can't be an issue on a game this old as it limits your FPS to 60Hz. I use it and do not have any problems as such. It limits my framerate to 60fps... Who need more, the human eye won't notice >25fps
  18. Andy Breedon SRP Manager

    I missed the 32x lol yes dont think that would help.

    I prefer a limited fps in fps games not in racing i do want more :) and hate a line in the middle of a screen when driving.
  19. Rob Hermans SRP Manager

    Michael, it's not about what your eye can perceive in terms of framerate; Vsync introduces input lag, particularly when used in conjunction with triple buffering. Unless you're limiting FPS, I firmly believe Vsync and triple buffering should be off.
    I agree that if your graphics can't handle 32x CSAA, it could cause stutter, but why only online and why only when you get near other cars?
  20. Michael van Scheppingen Licensed Driver

    It's a long Race07 story. My last Nvidia card was a 6800. (About 10 years ago?)
    Race07 never liked Nvidia much for whatever reason, can't remember as I am an AMD/ATI user.

    At TouringSixteenSeries (TPS) they blame the netcode = equal to rFactor's.. or the bonespring which has nothing to do with this.

    Tripple buffering is an OpenGL setting while this is a Dx9 game.

    Only set the resolution in the Race07 control panel. Don't use the AA enhancements. Always via the driver.

    Setting 32x CSAA on an old game won't enhance anything you'll notice except the drop in framerate. Start using 8xAA & 16xAF and check if that works out. Use Vsync if you like.

    Personally, I think it's a physics issue that causes the stutter. And there is no fix for that in default game. Drive one of the American muscle cars online and see if the issue persists. Why a muscle car? :)

    And Ryan, nothing wrong with your spec's. You might want an extra 4Gb of memory in the near future. That's something you'll notice :)

Share This Page